5G Communications - iPECS Cloud Outage – Incident details

All systems operational

iPECS Cloud Outage

Resolved
Operational
Started 6 months agoLasted about 5 hours

Affected

iPECS Cloud

Partial outage from 11:00 AM to 3:42 PM

Updates
  • Resolved
    Resolved

    Everything seems to be working but we will continue to monitor the service.

  • Monitoring
    Monitoring

    We are aware that some customers are having issues making and receiving calls on iPECS Cloud.
    We have noticed services coming back online and from testing it seems everything is working so far. We will continue to monitor the service.